Update Browser

To run Imagine Learning you need the most recent release of Firefox or Chrome running on a computer or Chromebook.

Alternatively, install the standalone Imagine Learning application for:

  • Windows
  • Mac OS X
  • Android
  • iOS